PDA

View Full Version : Disabling Smilies


Guerri Stevens
April 6th, 2006, 07:46 PM
I hunted around but could not find a way to disable the automatic substitution of a smilie (or is it smily) for certain combinations of characters. Is there a way to do that permanently rather than with each post?

Judy G. Russell
April 7th, 2006, 12:19 AM
I can't see a way, Guerri, but let me check into this for you.

Guerri Stevens
April 7th, 2006, 03:43 AM
I looked at all the various settings under the Control Panel. I have never noticed the smilies appearing in my messages before, but maybe I was just lucky. The thread on the plugins, though, gave me one when I included "about:plugins" in messages. ":p" produces a smilie.

Hmm, I just discovered that the Quick Reply doesn't have the disable option unless you use "go advanced".

Judy G. Russell
April 7th, 2006, 10:55 AM
Aha! Yes, you can disable them in a message you post in the advanced settings -- but I don't think there's any way you can disable them from displaying in a message where they haven't been disabled.

Peter Creasey
April 7th, 2006, 11:29 AM
could not find a way to disable the automatic substitution of a smilie (or is it smily) for certain combinations of characters. Is there a way to do that permanently rather than with each post?

Guerri, I don't like emoticons and never use them; however, I can't think of a good reason why you would want to disable them. Can you share with us your reason?

Guerri Stevens
April 7th, 2006, 02:30 PM
Guerri, I don't like emoticons and never use them; however, I can't think of a good reason why you would want to disable them. Can you share with us your reason?
I want to disable them because if you type certain combinations of characters you automatically get a smilie instead unless you scroll down to "additional options" before posting your message and turn off the option. For example, in a thread elsewhere, I typed "about:plugins" and the ":p" was translated into a smilie. I don't think that ever happened before, probably because I never before typed a character combination that would have resulted in a translation to a smilie. So I just wanted to disable them to prevent this happening in the future. I mean a permanent setting that would disable them for me so I wouldn't have to check the option with every message I write.

Guerri Stevens
April 7th, 2006, 02:35 PM
Aha! Yes, you can disable them in a message you post in the advanced settings -- but I don't think there's any way you can disable them from displaying in a message where they haven't been disabled.
I suppose that unintentionally hitting upon a character combination that would produce a smilie is rare. Otherwise, I would suggest that the default would be for smilies to be disabled and those who want to use them, would enable them.

I am pretty sure I've seen messages with smilies embedded in unusual places, which would mean that from time to time someone, like me, inadvertently uses one of the smilie character combinations.

Judy G. Russell
April 7th, 2006, 03:15 PM
If there was a setting to do that in a way that would be easy for the many many people who do use smilies, we'd do it. But I can't find an easy way. Sorry.

Guerri Stevens
April 7th, 2006, 03:54 PM
If there was a setting to do that in a way that would be easy for the many many people who do use smilies, we'd do it. But I can't find an easy way. Sorry.
Ideally this would be a setting that each person could turn on/off as part of a profile, so it would have to be done only once. But I can live with what we've got.

Judy G. Russell
April 7th, 2006, 05:36 PM
I agree. That would be perfect. But I don't see it in this version and I'm not quite ready to upgrade to the next version yet (and don't know that it would be there anyhooo!).

sidney
April 7th, 2006, 08:19 PM
I am pretty sure I've seen messages with smilies embedded in unusual places

I think I added to the confusion in the Sudoku thread. After I suggested about:plugins I noticed that :p is a smiley and used my moderator powers to switch off smileys in three messages in the thread that were messed up as a result, one from me, one from you, and one from Judy. I thought of it as cleanup rather than changing someone else's message. I apologize if you don't agree.

I also don't see any way to turn them off other then in a particular message that you are typing or editing. And to answer the earlier question as to why you would want to, you have to if you are trying to type something that contains any of the 11 character strings that correspond to the 11 smiley icons that this software uses.

-- sidney

Peter Creasey
April 8th, 2006, 02:19 PM
I want to disable them because if you type certain combinations of characters you automatically get a smilie instead unless you scroll down to "additional options" before posting your message and turn off the option.

Guerri, Oh! I thought you meant that you were disabling them on messages you are receiving (not composing).

I have never had this happen with any message I have composed.

Is this a common problem with online packages or just here? Also, I gather there is no way to disable them globally across my whole PC?

Guerri Stevens
April 8th, 2006, 04:51 PM
...Is this a common problem with online packages or just here? Also, I gather there is no way to disable them globally across my whole PC?
It probably depends on the forum software being used. Back in the olden days when there was nothing but text being used, we simulated them with character combinations, and my guess is that since they are still widely used, modern forum software translates the character strings by default. There is no profile setting in the software used here that allows you to turn them off by default for messages you send. You have to disable them in each message as you write it.

I only noticed it because a message I wrote happened to have a character combination that got translated into a smilie. Since I am still in the dark ages with dial-up access, I usually don't preview messages and didn't see it until the message was posted.